会议组件登录报错处理
更新时间: 2024/07/26 15:44:41
问题描述
会议组件登录时报错 100004 或者 100005。
问题原因
- 报错 100004 原因:客户端开启了复用 IM,但登录会议时,IM 并没有完成登录。
- 报错 100005 原因:登录传参的会议账号和当前已登录的 IM 账号不匹配。
解决方案
会议组件支持 IM 复用,在复用场景下登录会议组件,业务层需要确保完成以下逻辑:
- 业务层完成 IM SDK 的初始化。
- 在登录会议组件前业务层需要确保已经成功登录 IM。
- 业务层确保当前 IM 账号与会议账号匹配。
IM 复用的原理和流程可以请参考官方文档:复用 IM 账号。
此文档是否对你有帮助?